【大鱼叔叔|技术干货】解决gi.require_version('Gst', '1.0') 问题
大鱼叔叔 发布于2018-04-03 00:36 浏览:2059 回复:2
1
收藏

问题呈现:

pi@raspberrypi:~/DuerOS-Modularization $ sudo sh wakeup_trigger_start.sh 
Traceback (most recent call last):
File "./app/wakeup_trigger_main.py", line 28, in <module>
from app.framework.player import Player
File "/home/pi/DuerOS-Modularization/app/framework/player.py", line 9, in <module>
gi.require_version('Gst', '1.0')
AttributeError: 'module' object has no attribute 'require_version'

问题分析:

sudo pip install gi

这个一个错误的决定!

解决办法:

sudo apt-get update
sudo pip uninstall gi
sudo pip install tornado hyper
sudo apt install -y python-dateutil gir1.2-gstreamer-1.0 python-pyaudio libatlas-base-dev python-dev
sudo apt install -y python-requests python-gi python-configparser gstreamer1.0 openssl

温馨提示:

不用去管上面的依赖和库你有没有安装,直接复制执行,有问题可以qq交流。晚安,各位“度友”。

收藏
点赞
1
个赞
共2条回复 最后由大鱼叔叔回复于2018-04-04 12:53
#2DuerOS-河豚回复于2018-04-04

赞大鱼叔!

0
#3大鱼叔叔回复于2018-04-04
#2 DuerOS-河豚回复
赞大鱼叔!

来个置顶,哈哈哈

0
TOP